Download Chummer

Chummer is updated on a regular basis. If you already have Chummer installed, you can update your copy by selecting Check for Updates from the Tools menu.

Chummer's only system requirement is that you have Microsoft .NET Framework 4.0 installed.

Chummer does not need to be installed. Just download the zip file, unzip it to wherever you'd like, and start creating!

Current version: 490
Date: Jul 08 2013

Download Chummer!